[ORACLE]ORA-01950: 表領域’USERS’に対する権限がありません。のエラー対処法

投稿日:2020-09-02

 

Oracle 12c R2(R1でも同様のエラーが発生)で

ORA-01950: 表領域’USERS’に対する権限がありません

のエラーが発生しました。

状況としては、

ユーザ作成

権限付与

dmpファイルのインポート

の手順だったのですが、最後のdmpファイルインポート時にエラーが発生。

原因

原因は、先の手順

ユーザ作成

権限付与

dmpファイルのインポート

の権限付与時。

Oracle 11g R2での環境構築時に使用していたバッチをそのまま流用したためでした。

要は、権限不足・・・

対処法

alter user ユーザ名 quota unlimited on USERS(表領域名);

これで解決。

unlimitedでは無制限になるので、環境によっては調整が必要かもだけど。

以上。







-ORACLE
-

関連記事

[ORACLE]Oracleに接続できない時に確認すること

Oracleを新しくインストールした時に、中々接続できなかったので、その時に確認しておくべき事項のまとめ。 少なくとも、これは先にやっておいた方がいいこととか。 前提条件 前提と書くとものものしいけど …

[ORACLE]ORA-24344:正常に終了しましたが、コンパイル・エラーがあります。

全然、正常に終われてねぇんじゃん?? って思った。 ビューの作成時に発生。 ネットで検索するも、明確な回答は見当たらず・・・ ただ、エラーには違いないので、ビューが正しく作成されていないことになる。 …

[ORACLE]SQLのIN句にパラメータを適用する方法

カンマ区切りの文字列を取得した理由 こないだの続きです。 日本の中心付近で仕様変更と闘うSE日記[C#]リストをカンマ区切りの文字列で出力するhttp://ht-jp.net/blog/pc/c/c- …

Oracle Database Bronzeの勉強を始めました。

業務でOracleを使ってます。 DBへの接続と簡単なSQLの確認ぐらいだったら、SQLDeveloperとかのツールを使わずにSQLPlusだけで済ませちゃう人も多いのかな? あとは、SQLのバッチ …

[ORACLE]IMPコマンドで、複数テーブルをインポートする

OracleでIMPコマンドでdumpファイルをインポートする時に、特定のテーブルだけインポートしたい時ってある。 後は、複数のテーブルを纏めてインポートする方法を説明します。 Oracleを使ってる …


カテゴリー